Меню

1C Linux Установка клиента 1С:Предприятие 8.3 на Debian / Ubuntu

В последние годы интерес к альтернативным ОС, прежде всего Linux, возрастает, причем не только со стороны пользователей, но и со стороны разработчиков. Фирма 1С достаточно давно развивает свою платформу для использования в среде Linux, а теперь к ней стали подтягиваться производители торгового оборудования, выпуская драйвера и для этой ОС. Поэтому использование Linux в качестве платформы для рабочего места выглядит все более привлекательно и сегодня мы обобщим свой опыт и расскажем об установке клиентской части 1С:Предприятие в среде современных выпусков Debian / Ubuntu.

Если вы используете Debian, то мы рекомендуем подключить все репозитории, для этого откройте /etc/apt/sources.list и добавьте после main в каждую строку contrib и non-free.

Затем обновим список пакетов:

sudo apt update

и установим:

sudo apt install libwebkitgtk-3.0-0 ttf-mscorefonts-installer libfontconfig1 libgsf-1-114 libglib2.0-0 libodbc1

Часть пакетов у вас уже может быть установлена, это нормально, мы специально пошли по пути избыточности, ради универсальности данного материала.

Следующий пакет должен быть установлен по умолчанию, но на всякий случай следует проверить.

Для Ubuntu 16.04:

sudo apt install libmagickwand-6.q16-2

Для Debian 9 и Ubuntu 18.04:

sudo apt install libmagickwand-6.q16-3

Для установки клиентской версии платформы вам потребуется скачать с сайта 1С два архива: Клиент 1С:Предприятия для DEB-based Linux-систем и Cервер 1С:Предприятия для DEB-based Linux-систем. Обратите внимание, что разрядность скачиваемых архивов должна соответствовать разрядности системы, мы не видим особой необходимости в использовании x32 (i386) систем, поэтому в дальнейшем, если это не оговорено особо, все действия будут производиться для платформы x64 (amd64).

Коротко разберем состав архивов, в поставку клиента входят пакеты:

  • client – клиентские приложения (толстый клиент и тонкий клиент) «1С:Предприятия»
  • thin-client – тонкий клиент «1С:Предприятия» (не поддерживается работа с файловым вариантом информационной базы)

В состав сервера:

  • common – общие компоненты «1С:Предприятия»
  • server – компоненты сервера «1С:Предприятия»
  • ws – адаптер для публикации Web-сервисов «1С:Предприятия» на веб-сервере на основе Apache HTTP Server 2.0, 2.2 или 2.4

Также в поставке присутствуют пакеты с суффиксами -nls, они содержат языковые ресурсы, кроме русского и английского языков, поэтому если они вам не нужны, то их установка необязательна, в нашем примере мы их установим (исходя из принципа разумной избыточности, так как наш блог читают не только в России).

Создайте отдельную папку и скопируйте туда пакеты client из поставки Клиента и пакеты common и server из поставки Сервера, в итоге, с -nls, у вас должно оказаться шесть пакетов:

Теперь откроем консоль и перейдем в папку с пакетами, проще всего это сделать, щелкнув в ней правой кнопкой мыши и выбрать Открыть в терминале:

И установим пакеты командой:

dpkg -i 1c*.deb

Затем находим значок 1С в меню и запускаем приложение, все должно работать.

Для завершения процесса отключим автозапуск службы сервера 1С, которая для работы клиента не нужна, это необязательно, но желательно по соображениям экономии ресурсов и безопасности, для этого выполним:

systemctl disable srv1cv83

Как видим, ничего сложного в установке клиентской платформы 1С:Предприятие на Linux нет. Достаточно придерживаться инструкции и установить все необходимые зависимости.

Платформа 8.3.13 и ошибка с libpng12

При установке или обновлении до платформы 8.3.13, актуальный релиз на сегодня – 8.3.13.1513, вы можете столкнуться с ситуацией, когда 1С отказывается запускаться, эта ошибка проявляется в Debian 9 и Ubuntu 18.04.

Если запустить приложении из консоли, то мы увидим ошибку

После чего все становится на свои места. В новых дистрибутивах библиотеку libpng12 заменила libpng16, но 1С продолжает искать старую библиотеку (причем только последний релиз 8.3.13), оставим это на совести разработчиков 1С.

Что делать? Скачать нужный пакет из репозитория Debian 8 или Ubuntu 16.04. Непосредственно на системе это можно сделать командой (для x64 систем):

wget http://ftp.ru.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.50-2+deb8u3_amd64.deb

Для 32-х битных систем аналогичная команда будет:

wget http://ftp.ru.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.50-2+deb8u3_i386.deb

Затем установим пакет:

sudo dpkg  -i libpng12-0_1.2.50-2+deb8u3_amd64.deb

или для 32-х бит:

sudo dpkg  -i libpng12-0_1.2.50-2+deb8u3_i386.deb

После чего 1С снова начнет запускаться.

На этом Все!!! Всем Удачи!!!

 

302 Found

Found

The document has moved here.